Phishing simulator unavailable Wednesday 20. November 2019 16:25:00


Landing pages for simulated phishing have been taken down for maintenance. Availability will be restored as soon as possible, apologies for any service disturbance.

Update 09:15: A new server setup is soon available, check back at 10:00 for new update.

Update 10:17: Issue resolved. We apologise for any inconvenience, although our monitoring indicates that no customers have been affected by this incident.